Contract caching

Casey Z. shared this problem 26 days ago
Solved

Customers are having trouble seeing changes we make to contracts. I think the problem is they are being shown a cached page. I remember this happening many years ago. I believe Joel, or someone else fixed this by turning off caching for the contract page.

Comments (2)

photo
1

Do you have a couple examples?

photo
1

Just happened today with lead 29847485. Venue address was changed, but the client and my sales person couldn't see the update on the contract.

Yesterday on lead 29394056 the same thing happened, but I don't remember what the change was.

In both cases, control+F5 did not work. They couldn't see the new contract until I purged the cache on my website.

photo
1

Thank you! Taking a look...will keep you posted

photo
photo
1

I will look into this further, but usually we will disable cache on websites. You can do that for now, and I will let you know if we have a better solution.

photo
1

This is still happening. I checked my cache settings and I do have the contract page excluded from caching. This problem is currently happening with lead 30901215. The customer was sent a contract link, noticed the date was wrong, we changed the date and they cannot see the change. We even sent a new link and they still see the incorrect date. My salesperson is also seeing the incorrect date, but I see the new/correct date.

0a1c310fd1c176063bc6dd0a0199c03d

photo
1

This is still likely an issue with caching. I can see the correct times now. To test this - the next time you notice this occur, change the IO wordpress setting (under 'show advanced options') for "Checkout" from 'website' to 'IO'. The contract link will then open on our server directly and bypass the wordpress cache.

photo
1

If it is a caching issue, the caching will need to be completely disabled, or there is another plugin that is also caching the contracts.

photo
1

Also, don't forget to change that wordpress setting back after testing.

photo
1

Okay I did this and it worked. On lead 29346848, my customer and one salesperson could not see the updated contract. I switched the checkout to IO and they saw the new contract. I switched the checkout back to website and they could no longer see the updated contract.

So, what do I do now? Turn off all caching? My site was recently moved to a new server; is that what caused this?

photo
1

I've swapped your caching plugin with another one we recommend. This may help with the issue of it not clearing.

photo
Leave a Comment
 
Attach a file